CVE-2023-0050 Cross-site scripting in GitLab

High 8.7 Published Updated

Attackers can execute arbitrary scripts in victim browsers via crafted Kroki diagrams, potentially leading to account takeover or data modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-0050?

CVE-2023-0050 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 9 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 13.7 before 15.7.8, all versions starting from 15.8 before 15.8.4, all versions starting from 15.9 before 15.9.2. A specially crafted Kroki diagram could lead to a stored XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2023-0050?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.7.015.7.8, 15.8.4, 15.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-0050?

Upgrade gitlab to a fixed version for your release line: 15.7.8, 15.8.4 or 15.9.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-0050 being exploited?

There is no known exploitation of CVE-2023-0050 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-0050, GHSA-58vv-56m5-q92p, UBUNTU-CVE-2023-0050.

Is CVE-2023-0050 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free