# CVE-2023-0057: Improper Restriction of Rendered UI Layers or Frames in pyload/pyload

> Attackers can inject malicious scripts into the pyload web interface, potentially leading to session hijacking or arbitrary code execution.

- **Severity:** Low 3.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-h8r9-467r-vjjf, PYSEC-2026-904

## What is CVE-2023-0057?

CVE-2023-0057 is a low-severity cross-site scripting vulnerability in pyload/pyload, published on 5 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Restriction of Rendered UI Layers or Frames in GitHub repository pyload/pyload prior to 0.5.0b3.dev33.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2023-0057?

3 open source packages ship an affected version, including pyload-ng. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev33 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev33 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev33 |

Products: Pyload-Ng Project Pyload-Ng, Pyload Pyload.

## How do I fix CVE-2023-0057?

Upgrade pyload-ng to 0.5.0b3.dev33 or later.

## Is CVE-2023-0057 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0057 exists.

## Other vulnerabilities in pyload/pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-22416](https://insights.sbomify.com/CVE-2024-22416/): Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation (critical 9.7)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-35463](https://insights.sbomify.com/CVE-2026-35463/): pyLoad has Improper Neutralization of Special Elements used in an OS Command (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0057 and fix it if it is affected.

What it is: CVE-2023-0057 is a low-severity cross-site scripting vulnerability in pyload/pyload, published on 5 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0057 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev33
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev33
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0057/ (Markdown: https://insights.sbomify.com/CVE-2023-0057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0057
- OSV: https://osv.dev/vulnerability/CVE-2023-0057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0057/
Summaries are generated and may contain mistakes; the official description above is the record.
