# CVE-2023-0105: Keycloak: Impersonation and lockout possible through incorrect handling of email trust

> Attackers can impersonate or lock out users by exploiting incorrect email trust handling in Keycloak, leading to account takeover or denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2023
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-c7xw-p58w-h6fj

## What is CVE-2023-0105?

CVE-2023-0105 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. This flaw allows impersonation and lockout due to the email trust not being handled correctly in Keycloak. An attacker can shadow other users with the same email and lockout or impersonate them.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-0105?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 22.0.1 |
| `org.keycloak:keycloak-core` | Maven | All versions | 22.0.1 |

Products: Redhat Keycloak.

## How do I fix CVE-2023-0105?

Upgrade org.keycloak:keycloak-core to 22.0.1 or later.

## Is CVE-2023-0105 being exploited?

There is no known exploitation of CVE-2023-0105 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0105 and fix it if it is affected.

What it is: CVE-2023-0105 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0105 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 22.0.1
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 22.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0105/ (Markdown: https://insights.sbomify.com/CVE-2023-0105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0105
- OSV: https://osv.dev/vulnerability/CVE-2023-0105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0105/
Summaries are generated and may contain mistakes; the official description above is the record.
