# CVE-2023-0109: Stored XSS in usememos/memos

> Attackers can inject malicious scripts via uploaded files, leading to credential theft and session hijacking for users of the Memos web application.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2024
- **Updated:** 15 Nov 2024
- **Also known as:** GHSA-5r2g-59px-3q9w, GO-2024-3274

## What is CVE-2023-0109?

CVE-2023-0109 is a critical cross-site scripting vulnerability in Usememos Memos, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-0109?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/usememos/memos` | Go | All versions | 0.10.0 |
| `github.com/usememos/memos` | Go | All versions | 0.10.0 |
| `github.com/usememos/memos` | Go | All versions | 0.10.0 |

Products: Usememos Memos.

## How do I fix CVE-2023-0109?

Upgrade github.com/usememos/memos to 0.10.0 or later.

## Is CVE-2023-0109 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0109 exists.

## Other vulnerabilities in Usememos Memos

- [CVE-2025-50738](https://insights.sbomify.com/CVE-2025-50738/): Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs (critical 9.8)
- [CVE-2025-22952](https://insights.sbomify.com/CVE-2025-22952/): Memos Server-Side Request Forgery (SSRF) (critical 9.8)
- [CVE-2023-4696](https://insights.sbomify.com/CVE-2023-4696/): Improper Access Control in usememos/memos (critical 9.8)
- [CVE-2022-4866](https://insights.sbomify.com/CVE-2022-4866/): Cross-site Scripting (XSS) - Stored in usememos/memos (critical 9.8)
- [CVE-2022-4851](https://insights.sbomify.com/CVE-2022-4851/): Improper Handling of Values in usememos/memos (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0109 and fix it if it is affected.

What it is: CVE-2023-0109 is a critical cross-site scripting vulnerability in Usememos Memos, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0109 exists.

Affected packages and fixed versions:
- github.com/usememos/memos (Go): affected all versions; fixed in 0.10.0
- github.com/usememos/memos (Go): affected all versions; fixed in 0.10.0
- github.com/usememos/memos (Go): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0109/ (Markdown: https://insights.sbomify.com/CVE-2023-0109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0109
- OSV: https://osv.dev/vulnerability/CVE-2023-0109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0109/
Summaries are generated and may contain mistakes; the official description above is the record.
