CVE-2023-0120 Incorrect Authorization in GitLab

Low 3.5 Published Updated

An unauthorized user can modify label descriptions in GitLab due to improper permission validation, requiring an upgrade to secure the instance.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-0120?

CVE-2023-0120 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 10.0 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. Due to improper permission validation it was possible to edit labels description by an unauthorised user.

Weakness: CWE-863

Which versions are affected by CVE-2023-0120?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.0.016.1.5, 16.2.5, 16.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-0120?

Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-0120 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0120 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-0120, GHSA-h3r9-rg3q-7f5f, UBUNTU-CVE-2023-0120.

Is CVE-2023-0120 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free