CVE-2023-0121 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An attacker can cause high resource consumption and denial of service in GitLab by uploading malicious test report artifacts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-0121?

CVE-2023-0121 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service issue was discovered in GitLab CE/EE affecting all versions starting from 13.2.4 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2 which allows an attacker to cause high resource consumption using malicious test report artifacts.

Weakness: CWE-770

Which versions are affected by CVE-2023-0121?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.2.415.10.8, 15.11.7, 16.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-0121?

Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-0121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0121 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-0121, GHSA-2298-j2fr-472h, UBUNTU-CVE-2023-0121.

Is CVE-2023-0121 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free