# CVE-2023-0216: Invalid pointer dereference in d2i_PKCS7 functions

> Attackers can cause a denial of service by triggering an invalid pointer dereference in OpenSSL when processing malformed PKCS7 data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2023
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2023-0216, CLEANSTART-2026-UF28106, DEBIAN-CVE-2023-0216, GHSA-29xx-hcv2-c4cp, RUSTSEC-2023-0011, UBUNTU-CVE-2023-0216

## What is CVE-2023-0216?

CVE-2023-0216 is a high-severity vulnerability in Openssl Openssl, published on 8 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An invalid pointer dereference on read can be triggered when an
application tries to load malformed PKCS7 data with the
d2i_PKCS7(), d2i_PKCS7_bio() or d2i_PKCS7_fp() functions.

The result of the dereference is an application crash which could
lead to a denial of service attack. The TLS implementation in OpenSSL
does not call this function however third party applications might
call these functions on untrusted data.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2023-0216?

3 open source packages ship an affected version, including openssl-src. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |

Products: Openssl Openssl, Stormshield Stormshield Management Center.

## How do I fix CVE-2023-0216?

Upgrade openssl-src to 300.0.12 or later.

## Is CVE-2023-0216 being exploited?

There is no known exploitation of CVE-2023-0216 in the wild and no public exploit code.

## Other vulnerabilities in Openssl Openssl

- [CVE-2009-3245](https://insights.sbomify.com/CVE-2009-3245/): Null dereference in n/a (critical 10.0)
- [CVE-2006-3738](https://insights.sbomify.com/CVE-2006-3738/): Memory corruption in n/a (critical 10.0)
- [CVE-2026-63073](https://insights.sbomify.com/CVE-2026-63073/): Untrusted Sender DN Used as Format String in CMP Response Validation (critical 9.8)
- [CVE-2016-6309](https://insights.sbomify.com/CVE-2016-6309/): Use after free in n/a (critical 9.8)
- [CVE-2016-0799](https://insights.sbomify.com/CVE-2016-0799/): Integer overflow in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0216 and fix it if it is affected.

What it is: CVE-2023-0216 is a high-severity vulnerability in Openssl Openssl, published on 8 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0216 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0216/ (Markdown: https://insights.sbomify.com/CVE-2023-0216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0216
- OSV: https://osv.dev/vulnerability/CVE-2023-0216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0216/
Summaries are generated and may contain mistakes; the official description above is the record.
