# CVE-2023-0227: Insufficient Session Expiration in pyload/pyload

> Attackers can hijack user sessions due to insufficient expiration, allowing unauthorized access to the pyload web interface.

- **Severity:** High 8.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2023
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-rv9x-wmw4-44qj, PYSEC-2026-906

## What is CVE-2023-0227?

CVE-2023-0227 is a high-severity vulnerability in pyload/pyload, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-0227?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev36 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev36 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev36 |

Products: Pyload Pyload.

## How do I fix CVE-2023-0227?

Upgrade pyload-ng to 0.5.0b3.dev36 or later.

## Is CVE-2023-0227 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0227 exists.

## Other vulnerabilities in pyload/pyload

- [CVE-2023-0297](https://insights.sbomify.com/CVE-2023-0297/): Code Injection in pyload/pyload (critical 9.8)
- [CVE-2026-33992](https://insights.sbomify.com/CVE-2026-33992/): pyLoad: Server-Side Request Forgery via Download Link Submission Enables Cloud Metadata Exfiltration (critical 9.3)
- [CVE-2024-47821](https://insights.sbomify.com/CVE-2024-47821/): pyLoad vulnerable to remote code execution by download to /.pyload/scripts using /flashgot API (critical 9.1)
- [CVE-2024-32880](https://insights.sbomify.com/CVE-2024-32880/): pyLoad allows upload to arbitrary folder lead to RCE (critical 9.1)
- [CVE-2026-41133](https://insights.sbomify.com/CVE-2026-41133/): pyLoad has Stale Session Privilege After Role/Permission Change (Privilege Revocation Bypass) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0227 and fix it if it is affected.

What it is: CVE-2023-0227 is a high-severity vulnerability in pyload/pyload, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0227 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev36
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev36
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0227/ (Markdown: https://insights.sbomify.com/CVE-2023-0227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0227
- OSV: https://osv.dev/vulnerability/CVE-2023-0227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0227/
Summaries are generated and may contain mistakes; the official description above is the record.
