# CVE-2023-0241: pgAdmin 4 vulnerable to directory traversal

> Attackers can exploit directory traversal in pgAdmin 4 to modify other users' settings or alter the database.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-9crj-hpxh-f6qg, PYSEC-2026-1771, SUSE-SU-2023:1877-1

## What is CVE-2023-0241?

CVE-2023-0241 is a medium-severity path traversal vulnerability in pgadmin, published on 27 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin 4 versions prior to v6.19 contains a directory traversal vulnerability. A user of the product may change another user's settings or alter the database.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-0241?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 6.19 |
| `pgadmin4` | PyPI | All versions | 6.19 |
| `pgadmin4` | PyPI | All versions | 6.19 |
| `pgadmin4` | SUSE:Enterprise Storage 7.1 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Manager Proxy 4.2 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | SUSE:Manager Server 4.2 | All versions | 4.30-150300.3.9.1 |
| `pgadmin4` | openSUSE:Leap 15.4 | All versions | 4.30-150300.3.9.1 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2023-0241?

Upgrade pgadmin4 to 6.19 or later.

## Is CVE-2023-0241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0241 exists.

## Other vulnerabilities in pgadmin

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0241 and fix it if it is affected.

What it is: CVE-2023-0241 is a medium-severity path traversal vulnerability in pgadmin, published on 27 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0241 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 6.19
- pgadmin4 (PyPI): affected all versions; fixed in 6.19
- pgadmin4 (PyPI): affected all versions; fixed in 6.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0241/ (Markdown: https://insights.sbomify.com/CVE-2023-0241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0241
- OSV: https://osv.dev/vulnerability/CVE-2023-0241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0241/
Summaries are generated and may contain mistakes; the official description above is the record.
