# CVE-2023-0242: Insufficient permission check in the VQL copy() function

> Low-privilege users can overwrite server files, including configuration, due to missing write permission checks in the VQL copy function.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-g5vm-525q-r66c, GO-2023-1527

## What is CVE-2023-0242?

CVE-2023-0242 is a high-severity missing authorization vulnerability in Rapid7 Velociraptor, published on 18 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Rapid7 Velociraptor allows users to be created with different privileges on the server. Administrators are generally allowed to run any command on the server including writing arbitrary files. However, lower privilege users are generally forbidden from writing or modifying files on the server.

The VQL copy() function applies permission checks for reading files but does not check for permission to write files. This allows a low privilege user (usually, users with the Velociraptor "investigator" role) to overwrite files on the server, including Velociraptor configuration files.

To exploit this vulnerability, the attacker must already have a Velociraptor user account at a low privilege level (at least "analyst") and be able to log into the GUI and create a notebook where they can run the VQL query invoking the copy() VQL function. Typically, most users deploy Velociraptor with limited access to a trusted group (most users will be administrators within the GUI).
This vulnerability is associated with program files  https://github.Com/Velocidex/velociraptor/blob/master/vql/filesystem/copy.go https://github.Com/Velocidex/velociraptor/blob/master/vql/filesystem/copy.go  and program routines copy().

This issue affects Velociraptor versions before 0.6.7-5. Version 0.6.7-5, released January 16, 2023, fixes the issue.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-0242?

3 open source packages ship an affected version, including www.velocidex.com/golang/velociraptor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |

Products: Rapid7 Velociraptor.

## How do I fix CVE-2023-0242?

Upgrade www.velocidex.com/golang/velociraptor to 0.6.7-5 or later.

## Is CVE-2023-0242 being exploited?

There is no known exploitation of CVE-2023-0242 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 Velociraptor

- [CVE-2023-5950](https://insights.sbomify.com/CVE-2023-5950/): Rapid7 Velociraptor Reflected XSS (high 8.6)
- [CVE-2026-5329](https://insights.sbomify.com/CVE-2026-5329/): Rapid7 Velociraptor Improper Input Validation in Client Message Handler (high 8.5)
- [CVE-2026-6290](https://insights.sbomify.com/CVE-2026-6290/): Velociraptor Query() Plugin Misapplies Permissions To Orgs (high 8.0)
- [CVE-2025-14728](https://insights.sbomify.com/CVE-2025-14728/): Rapid7 Velociraptor Directory Traversal Vulnerability (medium 6.8)
- [CVE-2022-35630](https://insights.sbomify.com/CVE-2022-35630/): Unsafe HTML Injection in Artifact Collection Report (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0242 and fix it if it is affected.

What it is: CVE-2023-0242 is a high-severity missing authorization vulnerability in Rapid7 Velociraptor, published on 18 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0242 in the wild and no public exploit code.

Affected packages and fixed versions:
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0242/ (Markdown: https://insights.sbomify.com/CVE-2023-0242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0242
- OSV: https://osv.dev/vulnerability/CVE-2023-0242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0242/
Summaries are generated and may contain mistakes; the official description above is the record.
