# CVE-2023-0247: Uncontrolled Search Path Element in bits-and-blooms/bloom

> An attacker can exploit an uncontrolled search path to load malicious libraries, potentially leading to code execution in applications using this Go library.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** GHSA-fgwp-pwqq-g3w4

## What is CVE-2023-0247?

CVE-2023-0247 is a high-severity path traversal vulnerability in bits-and-blooms/bloom, published on 12 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Uncontrolled Search Path Element in GitHub repository bits-and-blooms/bloom prior to 3.3.1.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2023-0247?

2 open source packages ship an affected version, including github.com/bits-and-blooms/bloom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bits-and-blooms/bloom` | Go | All versions | 3.3.1 |
| `github.com/bits-and-blooms/bloom` | Go | All versions | 3.3.1 |

Products: Bloom Project Bloom.

## How do I fix CVE-2023-0247?

Upgrade github.com/bits-and-blooms/bloom to 3.3.1 or later.

## Is CVE-2023-0247 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0247 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0247 and fix it if it is affected.

What it is: CVE-2023-0247 is a high-severity path traversal vulnerability in bits-and-blooms/bloom, published on 12 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0247 exists.

Affected packages and fixed versions:
- github.com/bits-and-blooms/bloom (Go): affected all versions; fixed in 3.3.1
- github.com/bits-and-blooms/bloom (Go): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0247/ (Markdown: https://insights.sbomify.com/CVE-2023-0247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0247
- OSV: https://osv.dev/vulnerability/CVE-2023-0247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0247/
Summaries are generated and may contain mistakes; the official description above is the record.
