# CVE-2023-0264: Keycloak vulnerable to user impersonation via stolen UUID code

> An authenticated attacker can impersonate victims and generate session tokens by exploiting an OpenID Connect authentication flaw in Keycloak.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9g98-5mj6-f9mv

## What is CVE-2023-0264?

CVE-2023-0264 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloaks OpenID Connect user authentication, which may incorrectly authenticate requests. An authenticated attacker who could obtain information from a user request within the same realm could use that data to impersonate the victim and generate new session tokens. This issue could impact confidentiality, integrity, and availability.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-0264?

2 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.0.1 |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.0.1 |

Products: Redhat Keycloak, Redhat Openshift Container Platform, Redhat Openshift Container Platform for Ibm Linuxone, Redhat Openshift Container Platform Ibm Z Systems, Redhat Single Sign-On.

## How do I fix CVE-2023-0264?

Upgrade org.keycloak:keycloak-services to 21.0.1 or later.

## Is CVE-2023-0264 being exploited?

There is no known exploitation of CVE-2023-0264 in the wild and no public exploit code.

Public exploit code:

- A small PoC for the Keycloak vulnerability CVE-2023-0264 (github_poc): https://github.com/twwd/CVE-2023-0264
- https://github.com/ElianGonzi00/pocKeycloakCVE-2023-0264 (github_poc): https://github.com/ElianGonzi00/pocKeycloakCVE-2023-0264

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0264 and fix it if it is affected.

What it is: CVE-2023-0264 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 4 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0264 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.0.1
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0264/ (Markdown: https://insights.sbomify.com/CVE-2023-0264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0264
- OSV: https://osv.dev/vulnerability/CVE-2023-0264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0264/
Summaries are generated and may contain mistakes; the official description above is the record.
