# CVE-2023-0290: Rapid7 Velociraptor directory traversal in client ID parameter

> An investigator-level user can exploit directory traversal to schedule server-side collections, escalating privileges to administrator level.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-7jf5-fvgf-48c6, GO-2023-1502

## What is CVE-2023-0290?

CVE-2023-0290 is a medium-severity path traversal vulnerability in Rapid7 Velociraptor, published on 18 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Rapid7 Velociraptor did not properly sanitize the client ID parameter to the CreateCollection API, allowing a directory traversal in where the collection task could be written. It was possible to provide a client id of "../clients/server" to schedule the collection for the server (as a server artifact), but only require privileges to schedule collections on the client.

Normally, to schedule an artifact on the server, the COLLECT_SERVER permission is required. This permission is normally only granted to "administrator" role. Due to this issue, it is sufficient to have the COLLECT_CLIENT privilege, which is normally granted to the "investigator" role.
To exploit this vulnerability, the attacker must already have a Velociraptor user account at least "investigator" level, and be able to authenticate to the GUI and issue an API call to the backend. Typically, most users deploy Velociraptor with limited access to a trusted group, and most users will already be administrators within the GUI.

This issue affects Velociraptor versions before 0.6.7-5. Version 0.6.7-5, released January 16, 2023, fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-0290?

3 open source packages ship an affected version, including www.velocidex.com/golang/velociraptor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |
| `www.velocidex.com/golang/velociraptor` | Go | All versions | 0.6.7-5 |

Products: Rapid7 Velociraptor.

## How do I fix CVE-2023-0290?

Upgrade www.velocidex.com/golang/velociraptor to 0.6.7-5 or later.

## Is CVE-2023-0290 being exploited?

There is no known exploitation of CVE-2023-0290 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 Velociraptor

- [CVE-2023-0242](https://insights.sbomify.com/CVE-2023-0242/): Insufficient permission check in the VQL copy() function (high 8.8)
- [CVE-2023-5950](https://insights.sbomify.com/CVE-2023-5950/): Rapid7 Velociraptor Reflected XSS (high 8.6)
- [CVE-2026-5329](https://insights.sbomify.com/CVE-2026-5329/): Rapid7 Velociraptor Improper Input Validation in Client Message Handler (high 8.5)
- [CVE-2026-6290](https://insights.sbomify.com/CVE-2026-6290/): Velociraptor Query() Plugin Misapplies Permissions To Orgs (high 8.0)
- [CVE-2025-14728](https://insights.sbomify.com/CVE-2025-14728/): Rapid7 Velociraptor Directory Traversal Vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0290 and fix it if it is affected.

What it is: CVE-2023-0290 is a medium-severity path traversal vulnerability in Rapid7 Velociraptor, published on 18 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0290 in the wild and no public exploit code.

Affected packages and fixed versions:
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5
- www.velocidex.com/golang/velociraptor (Go): affected all versions; fixed in 0.6.7-5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0290/ (Markdown: https://insights.sbomify.com/CVE-2023-0290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0290
- OSV: https://osv.dev/vulnerability/CVE-2023-0290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0290/
Summaries are generated and may contain mistakes; the official description above is the record.
