# CVE-2023-0298: Incorrect Authorization in firefly-iii/firefly-iii

> Attackers can access or modify data belonging to other users due to incorrect authorization checks in Firefly III.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** GHSA-7mc4-jp4f-v2j2

## What is CVE-2023-0298?

CVE-2023-0298 is a medium-severity missing authorization vulnerability in firefly-iii/firefly-iii, published on 14 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-0298?

2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grumpydictator/firefly-iii` | Packagist | All versions | 5.8.0 |
| `grumpydictator/firefly-iii` | Packagist | All versions | 5.8.0 |

Products: Firefly-Iii Firefly Iii.

## How do I fix CVE-2023-0298?

Upgrade grumpydictator/firefly-iii to 5.8.0 or later.

## Is CVE-2023-0298 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0298 exists.

## Other vulnerabilities in firefly-iii/firefly-iii

- [CVE-2021-3728](https://insights.sbomify.com/CVE-2021-3728/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3730](https://insights.sbomify.com/CVE-2021-3730/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3846](https://insights.sbomify.com/CVE-2021-3846/): Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii (medium 6.3)
- [CVE-2024-22075](https://insights.sbomify.com/CVE-2024-22075/): Firefly III allows webhooks HTML Injection. (medium 6.1)
- [CVE-2019-14667](https://insights.sbomify.com/CVE-2019-14667/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0298 and fix it if it is affected.

What it is: CVE-2023-0298 is a medium-severity missing authorization vulnerability in firefly-iii/firefly-iii, published on 14 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0298 exists.

Affected packages and fixed versions:
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 5.8.0
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0298/ (Markdown: https://insights.sbomify.com/CVE-2023-0298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0298
- OSV: https://osv.dev/vulnerability/CVE-2023-0298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0298/
Summaries are generated and may contain mistakes; the official description above is the record.
