# CVE-2023-0299: Improper Input Validation in publify/publify

> Improper input validation in Publify allows attackers to potentially cause unexpected behavior or errors.

- **Severity:** High 8.4 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** BIT-publify-2023-0299, GHSA-q3rm-f527-ghxj

## What is CVE-2023-0299?

CVE-2023-0299 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-0299?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify` | Bitnami | All versions | 9.2.10 |

Products: Publify Project Publify.

## How do I fix CVE-2023-0299?

Upgrade publify_core to 9.2.10 or later.

## Is CVE-2023-0299 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0299 exists.

## Other vulnerabilities in publify/publify

- [CVE-2022-1810](https://insights.sbomify.com/CVE-2022-1810/): Authorization Bypass Through User-Controlled Key in publify/publify (critical 9.9)
- [CVE-2022-1811](https://insights.sbomify.com/CVE-2022-1811/): Unrestricted Upload of File with Dangerous Type in publify/publify (critical 9.1)
- [CVE-2022-1553](https://insights.sbomify.com/CVE-2022-1553/): Leaking password protected articles content due to improper access control in publify/publify (high 8.8)
- [CVE-2023-0569](https://insights.sbomify.com/CVE-2023-0569/): Weak Password Requirements in publify/publify (high 8.1)
- [CVE-2022-1812](https://insights.sbomify.com/CVE-2022-1812/): Integer Overflow or Wraparound in publify/publify (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0299 and fix it if it is affected.

What it is: CVE-2023-0299 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0299 exists.

Affected packages and fixed versions:
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify (Bitnami): affected all versions; fixed in 9.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0299/ (Markdown: https://insights.sbomify.com/CVE-2023-0299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0299
- OSV: https://osv.dev/vulnerability/CVE-2023-0299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0299/
Summaries are generated and may contain mistakes; the official description above is the record.
