# CVE-2023-0315: Command Injection in froxlor/froxlor

> Attackers can execute arbitrary commands on the server hosting the Froxlor web application.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** GHSA-cp68-42pf-6627

## What is CVE-2023-0315?

CVE-2023-0315 is a high-severity command injection vulnerability in froxlor/froxlor, published on 16 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Command Injection in GitHub repository froxlor/froxlor prior to 2.0.8.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-0315?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.0.8 |
| `froxlor/froxlor` | Packagist | All versions | 2.0.8 |

Products: Froxlor Froxlor.

## How do I fix CVE-2023-0315?

Upgrade froxlor/froxlor to 2.0.8 or later.

## Is CVE-2023-0315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0315 exists.

Public exploit code:

- The official exploit for Froxlor Remote Code Execution CVE-2023-0315 (github_poc): https://github.com/mhaskar/CVE-2023-0315
- Froxlor Log Path RCE (metasploit)
- Froxlor 2.0.3 Stable - Remote Code Execution (RCE) (exploitdb)

## Other vulnerabilities in froxlor/froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0315 and fix it if it is affected.

What it is: CVE-2023-0315 is a high-severity command injection vulnerability in froxlor/froxlor, published on 16 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0315 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.0.8
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0315/ (Markdown: https://insights.sbomify.com/CVE-2023-0315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0315
- OSV: https://osv.dev/vulnerability/CVE-2023-0315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0315/
Summaries are generated and may contain mistakes; the official description above is the record.
