# CVE-2023-0334: ShortPixel Adaptive Images < 3.6.3 - Reflected XSS

> Reflected XSS in ShortPixel Adaptive Images allows attackers to execute scripts against high-privilege users, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-w9f3-8wj5-2vvr

## What is CVE-2023-0334?

CVE-2023-0334 is a medium-severity cross-site scripting vulnerability in Unknown ShortPixel Adaptive Images, published on 27 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The ShortPixel Adaptive Images WordPress plugin before 3.6.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against any high privilege users such as admin

## Which versions are affected by CVE-2023-0334?

It affects 1 product.


Products: Shortpixel Shortpixel Adaptive Images.

## How do I fix CVE-2023-0334?

No fix has been published for CVE-2023-0334 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-0334 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0334 exists.

Public exploit code:

- ShortPixel Adaptive Images < 3.6.3 - Cross Site Scripting (nuclei): http/cves/2023/CVE-2023-0334.yaml

## Other vulnerabilities in Unknown ShortPixel Adaptive Images

- [CVE-2023-32512](https://insights.sbomify.com/CVE-2023-32512/): WordPress ShortPixel Adaptive Images Plugin <= 3.7.1 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)
- [CVE-2022-29417](https://insights.sbomify.com/CVE-2022-29417/): WordPress ShortPixel Adaptive Images plugin <= 3.3.1 - Subscriber+ Plugin Settings Update vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0334 and fix it if it is affected.

What it is: CVE-2023-0334 is a medium-severity cross-site scripting vulnerability in Unknown ShortPixel Adaptive Images, published on 27 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0334 exists.

Affected product: Unknown ShortPixel Adaptive Images. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0334/ (Markdown: https://insights.sbomify.com/CVE-2023-0334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0334
- OSV: https://osv.dev/vulnerability/CVE-2023-0334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0334/
Summaries are generated and may contain mistakes; the official description above is the record.
