# CVE-2023-0434: Improper Input Validation in pyload/pyload

> Improper input validation in pyload allows attackers to potentially disrupt service or execute unintended actions, requiring an upgrade to the latest version.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:P/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2023
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-x9vc-5q77-m7x4, PYSEC-2026-908

## What is CVE-2023-0434?

CVE-2023-0434 is a medium-severity vulnerability in pyload/pyload, published on 22 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Input Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev40.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-0434?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev40 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev40 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev40 |

Products: Pyload Pyload.

## How do I fix CVE-2023-0434?

Upgrade pyload-ng to 0.5.0b3.dev40 or later.

## Is CVE-2023-0434 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0434 exists.

## Other vulnerabilities in pyload/pyload

- [CVE-2023-0297](https://insights.sbomify.com/CVE-2023-0297/): Code Injection in pyload/pyload (critical 9.8)
- [CVE-2026-33992](https://insights.sbomify.com/CVE-2026-33992/): pyLoad: Server-Side Request Forgery via Download Link Submission Enables Cloud Metadata Exfiltration (critical 9.3)
- [CVE-2024-47821](https://insights.sbomify.com/CVE-2024-47821/): pyLoad vulnerable to remote code execution by download to /.pyload/scripts using /flashgot API (critical 9.1)
- [CVE-2024-32880](https://insights.sbomify.com/CVE-2024-32880/): pyLoad allows upload to arbitrary folder lead to RCE (critical 9.1)
- [CVE-2026-41133](https://insights.sbomify.com/CVE-2026-41133/): pyLoad has Stale Session Privilege After Role/Permission Change (Privilege Revocation Bypass) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0434 and fix it if it is affected.

What it is: CVE-2023-0434 is a medium-severity vulnerability in pyload/pyload, published on 22 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0434 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev40
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev40
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0434/ (Markdown: https://insights.sbomify.com/CVE-2023-0434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0434
- OSV: https://osv.dev/vulnerability/CVE-2023-0434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0434/
Summaries are generated and may contain mistakes; the official description above is the record.
