# CVE-2023-0470: Cross-site Scripting (XSS) - Stored in modoboa/modoboa

> Attackers can inject malicious scripts into Modoboa, potentially stealing user sessions or executing code in victim browsers.

- **Severity:** High 7.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2023
- **Updated:** 31 Mar 2025
- **Also known as:** GHSA-c467-5c2g-jp86, PYSEC-2023-30

## What is CVE-2023-0470?

CVE-2023-0470 is a high-severity cross-site scripting vulnerability in modoboa/modoboa, published on 26 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in GitHub repository modoboa/modoboa prior to 2.0.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-0470?

3 open source packages ship an affected version, including modoboa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modoboa` | PyPI | All versions | 2.0.4 |
| `modoboa` | PyPI | All versions | 2.0.4 |
| `modoboa` | PyPI | All versions | 2.0.4 |

Products: Modoboa Modoboa.

## How do I fix CVE-2023-0470?

Upgrade modoboa to 2.0.4 or later.

## Is CVE-2023-0470 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0470 exists.

## Other vulnerabilities in modoboa/modoboa

- [CVE-2023-5688](https://insights.sbomify.com/CVE-2023-5688/): Cross-site Scripting (XSS) - DOM in modoboa/modoboa (critical 9.8)
- [CVE-2023-2227](https://insights.sbomify.com/CVE-2023-2227/): Improper Authorization in modoboa/modoboa (critical 9.1)
- [CVE-2023-0777](https://insights.sbomify.com/CVE-2023-0777/): Authentication Bypass by Primary Weakness in modoboa/modoboa (high 8.6)
- [CVE-2026-27602](https://insights.sbomify.com/CVE-2026-27602/): Modoboa has an OS Command Injection (high 7.2)
- [CVE-2023-5689](https://insights.sbomify.com/CVE-2023-5689/): Cross-site Scripting (XSS) - DOM in modoboa/modoboa (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0470 and fix it if it is affected.

What it is: CVE-2023-0470 is a high-severity cross-site scripting vulnerability in modoboa/modoboa, published on 26 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0470 exists.

Affected packages and fixed versions:
- modoboa (PyPI): affected all versions; fixed in 2.0.4
- modoboa (PyPI): affected all versions; fixed in 2.0.4
- modoboa (PyPI): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0470/ (Markdown: https://insights.sbomify.com/CVE-2023-0470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0470
- OSV: https://osv.dev/vulnerability/CVE-2023-0470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0470/
Summaries are generated and may contain mistakes; the official description above is the record.
