# CVE-2023-0475: Go-Getter Vulnerable to Decompression Bombs

> Attackers can cause denial of service in applications using HashiCorp go-getter by submitting decompression bombs.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** AZL-13586, AZL-13606, DEBIAN-CVE-2023-0475, GHSA-jpxj-2jvg-6jv9, GO-2023-1578, UBUNTU-CVE-2023-0475

## What is CVE-2023-0475?

CVE-2023-0475 is a medium-severity denial of service vulnerability in HashiCorp go-getter, published on 16 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

HashiCorp go-getter up to 1.6.2 and 2.1.1 is vulnerable to decompression bombs. Fixed in 1.7.0 and 2.2.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2023-0475?

6 open source packages ship an affected version, including github.com/hashicorp/go-getter and github.com/hashicorp/go-getter/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.7.0 |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.7.0 |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.7.0 |
| `github.com/hashicorp/go-getter/v2` | Go | From 2.0.0 | 2.2.0 |
| `github.com/hashicorp/go-getter/v2` | Go | From 2.0.0 | 2.2.0 |
| `github.com/hashicorp/go-getter/v2` | Go | From 2.0.0 | 2.2.0 |

Products: Hashicorp Go-Getter.

## How do I fix CVE-2023-0475?

Upgrade github.com/hashicorp/go-getter to 1.7.0 or later.

## Is CVE-2023-0475 being exploited?

There is no known exploitation of CVE-2023-0475 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp go-getter

- [CVE-2024-3817](https://insights.sbomify.com/CVE-2024-3817/): HashiCorp go-getter Vulnerable to Argument Injection When Fetching Remote Default Git Branches (critical 9.8)
- [CVE-2022-26945](https://insights.sbomify.com/CVE-2022-26945/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-30321](https://insights.sbomify.com/CVE-2022-30321/): Path traversal in n/a (high 8.6)
- [CVE-2022-30322](https://insights.sbomify.com/CVE-2022-30322/): Denial of service in n/a (high 8.6)
- [CVE-2022-30323](https://insights.sbomify.com/CVE-2022-30323/): Denial of service in n/a (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0475 and fix it if it is affected.

What it is: CVE-2023-0475 is a medium-severity denial of service vulnerability in HashiCorp go-getter, published on 16 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0475 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.7.0
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.7.0
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.7.0
- github.com/hashicorp/go-getter/v2 (Go): affected from 2.0.0; fixed in 2.2.0
- github.com/hashicorp/go-getter/v2 (Go): affected from 2.0.0; fixed in 2.2.0
- github.com/hashicorp/go-getter/v2 (Go): affected from 2.0.0; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0475/ (Markdown: https://insights.sbomify.com/CVE-2023-0475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0475
- OSV: https://osv.dev/vulnerability/CVE-2023-0475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0475/
Summaries are generated and may contain mistakes; the official description above is the record.
