# CVE-2023-0508: Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting') in GitLab

> Attackers can exploit HTTP response splitting in the NPM package API to perform open redirects, potentially leading to phishing or session hijacking.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 7 Jan 2025
- **Also known as:** BIT-gitlab-2023-0508, GHSA-qx55-2cp2-7ppq, UBUNTU-CVE-2023-0508

## What is CVE-2023-0508?

CVE-2023-0508 is a low-severity vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. Open redirection was possible via HTTP response splitting in the NPM package API.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2023-0508?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 12.9.0 | 15.10.8, 15.11.7, 16.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-0508?

Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.

## Is CVE-2023-0508 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0508 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0508 and fix it if it is affected.

What it is: CVE-2023-0508 is a low-severity vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0508 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 12.9.0; fixed in 15.10.8, 15.11.7, 16.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0508/ (Markdown: https://insights.sbomify.com/CVE-2023-0508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0508
- OSV: https://osv.dev/vulnerability/CVE-2023-0508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0508/
Summaries are generated and may contain mistakes; the official description above is the record.
