CVE-2023-0518 Denial of service in GitLab

Medium 4.3 Published Updated

Attackers can cause a denial of service in GitLab by uploading a malicious Helm chart, requiring administrators to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-0518?

CVE-2023-0518 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.0 before 15.6.7, all versions starting from 15.7 before 15.7.6, all versions starting from 15.8 before 15.8.1. It was possible to trigger a DoS attack by uploading a malicious Helm chart.

Weakness: CWE-400

Which versions are affected by CVE-2023-0518?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.0.015.6.7, 15.7.6, 15.8.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-0518?

Upgrade gitlab to a fixed version for your release line: 15.6.7, 15.7.6 or 15.8.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-0518 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0518 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-0518, CVE-2023-0885, GHSA-9mqm-5q47-gj7c, UBUNTU-CVE-2023-0518.

Is CVE-2023-0518 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free