CVE-2023-0523 Cross-site scripting in GitLab
An attacker can execute arbitrary scripts in victim browsers via a malicious email address, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-0523?
CVE-2023-0523 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.6 before 15.8.5, 15.9 before 15.9.4, and 15.10 before 15.10.1. An XSS was possible via a malicious email address for certain instances.
Weakness: CWE-79
Which versions are affected by CVE-2023-0523?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.6.0 | 15.8.5, 15.9.4, 15.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-0523?
Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-0523 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0523 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-0523, GHSA-qgpv-xwh3-9v79, UBUNTU-CVE-2023-0523.