{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-0549 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-0549 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-0549 is a low-severity cross-site scripting vulnerability in YAFNET, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-0549 and fix it if it is affected.\n\nWhat it is: CVE-2023-0549 is a low-severity cross-site scripting vulnerability in YAFNET, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-0549 in the wild and no public exploit code.\n\nAffected product: YAFNET. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0549/ (Markdown: https://insights.sbomify.com/CVE-2023-0549/index.md)","id":"CVE-2023-0549","markdown":"https://insights.sbomify.com/CVE-2023-0549/index.md","name":"CVE-2023-0549","record":{"aliases":["GHSA-4hwx-678w-9cp5","GHSA-x86c-f9fh-89cx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"YAFNET forum software","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via private message fields in YAFNET, potentially executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"yaf.net","vendor":"yetanotherforum"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in YAFNET up to 3.1.10. This issue affects some unknown processing of the file /forum/PostPrivateMessage of the component Private Message Handler. The manipulation of the argument subject/message leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.11 is able to address this issue. The identifier of the patch is 2237a9d552e258a43570bb478a92a5505e7c8797. It is recommended to upgrade the affected component. The identifier VDB-219665 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"YAFNET Private Message PostPrivateMessage cross site scripting","id":"CVE-2023-0549","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2023"},"n_packages":0,"n_references":6,"next":{"headline":"Quick Restaurant Menu \u003c= 2.0.2 - Insecure Direct Object Reference","id":"CVE-2023-0550"},"packages":[],"prev":{"headline":"Namaste! LMS \u003c 2.5.9.4 - Admin+ Stored XSS","id":"CVE-2023-0548"},"products":["YAFNET"],"published":"2023-01-27","related":[{"cvss_score":3.5,"headline":"YAFNET Signature cross site scripting","id":"CVE-2023-0650","kev_date_added":null,"published":"2023-02-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-28","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via private message fields in YAFNET, potentially executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2023-0549/"}