# CVE-2023-0549: YAFNET Private Message PostPrivateMessage cross site scripting

> Attackers can inject malicious scripts via private message fields in YAFNET, potentially executing code in victim browsers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Jan 2023
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-4hwx-678w-9cp5, GHSA-x86c-f9fh-89cx

## What is CVE-2023-0549?

CVE-2023-0549 is a low-severity cross-site scripting vulnerability in YAFNET, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in YAFNET up to 3.1.10. This issue affects some unknown processing of the file /forum/PostPrivateMessage of the component Private Message Handler. The manipulation of the argument subject/message leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.11 is able to address this issue. The identifier of the patch is 2237a9d552e258a43570bb478a92a5505e7c8797. It is recommended to upgrade the affected component. The identifier VDB-219665 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-0549?

It affects 1 product.


Products: Yetanotherforum Yaf.net.

## How do I fix CVE-2023-0549?

No fix has been published for CVE-2023-0549 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-0549 being exploited?

There is no known exploitation of CVE-2023-0549 in the wild and no public exploit code.

## Other vulnerabilities in YAFNET

- [CVE-2023-0650](https://insights.sbomify.com/CVE-2023-0650/): YAFNET Signature cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0549 and fix it if it is affected.

What it is: CVE-2023-0549 is a low-severity cross-site scripting vulnerability in YAFNET, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0549 in the wild and no public exploit code.

Affected product: YAFNET. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0549/ (Markdown: https://insights.sbomify.com/CVE-2023-0549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0549
- OSV: https://osv.dev/vulnerability/CVE-2023-0549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0549/
Summaries are generated and may contain mistakes; the official description above is the record.
