# CVE-2023-0564: Weak Password Requirements in froxlor/froxlor

> Weak password requirements in Froxlor allow attackers to guess credentials and take over user accounts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2023
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-pm72-27mg-fc28

## What is CVE-2023-0564?

CVE-2023-0564 is a medium-severity vulnerability in froxlor/froxlor, published on 29 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weak Password Requirements in GitHub repository froxlor/froxlor prior to 2.0.10.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2023-0564?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.0.10 |
| `froxlor/froxlor` | Packagist | All versions | 2.0.10 |

Products: Froxlor Froxlor.

## How do I fix CVE-2023-0564?

Upgrade froxlor/froxlor to 2.0.10 or later.

## Is CVE-2023-0564 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0564 exists.

## Other vulnerabilities in froxlor/froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0564 and fix it if it is affected.

What it is: CVE-2023-0564 is a medium-severity vulnerability in froxlor/froxlor, published on 29 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0564 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.0.10
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0564/ (Markdown: https://insights.sbomify.com/CVE-2023-0564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0564
- OSV: https://osv.dev/vulnerability/CVE-2023-0564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0564/
Summaries are generated and may contain mistakes; the official description above is the record.
