{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-0567 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.0.28, 8.1.16 or 8.2.3.","what":"CVE-2023-0567 is a high-severity authentication bypass vulnerability in Php Php, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-0567 and fix it if it is affected.\n\nWhat it is: CVE-2023-0567 is a high-severity authentication bypass vulnerability in Php Php, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-0567 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3\n- php (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3\n- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0567/ (Markdown: https://insights.sbomify.com/CVE-2023-0567/index.md)","id":"CVE-2023-0567","markdown":"https://insights.sbomify.com/CVE-2023-0567/index.md","name":"CVE-2023-0567","record":{"aliases":["AZL-13740","BIT-libphp-2023-0567","BIT-php-2023-0567","BIT-php-min-2023-0567","DEBIAN-CVE-2023-0567","ECHO-9fe9-6b49-081e","GHSA-7fj2-8x79-rjf4","UBUNTU-CVE-2023-0567","USN-6053-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP core library","requires_auth":"none","summary":"Attackers can bypass authentication if invalid Blowfish hashes are stored, as password_verify incorrectly accepts them as valid.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-916","name":"Use of Password Hash With Insufficient Computational Effort"}],"description":"In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, password_verify() function may accept some invalid Blowfish hashes as valid. If such invalid hash ever ends up in the password database, it may lead to an application allowing any password for this entry as valid.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"password_verify() always returns true for some invalid hashes","id":"CVE-2023-0567","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"auth_bypass","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Array overrun in common path resolve code","id":"CVE-2023-0568"},"packages":[{"ecosystem":"Bitnami","fixed":["8.0.28","8.1.16","8.2.3"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2023-0567"},{"ecosystem":"Bitnami","fixed":["8.0.28","8.1.16","8.2.3"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2023-0567"},{"ecosystem":"Bitnami","fixed":["8.0.28","8.1.16","8.2.3"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2023-0567"}],"prev":{"headline":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in froxlor/froxlor","id":"CVE-2023-0566"},"products":["PHP"],"published":"2023-02-16","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-19","vendors":["PHP Group"]},"summary":"Attackers can bypass authentication if invalid Blowfish hashes are stored, as password_verify incorrectly accepts them as valid.","url":"https://insights.sbomify.com/CVE-2023-0567/"}