# CVE-2023-0567: password_verify() always returns true for some invalid hashes

> Attackers can bypass authentication if invalid Blowfish hashes are stored, as password_verify incorrectly accepts them as valid.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 19 Jul 2026
- **Also known as:** AZL-13740, BIT-libphp-2023-0567, BIT-php-2023-0567, BIT-php-min-2023-0567, DEBIAN-CVE-2023-0567, ECHO-9fe9-6b49-081e, GHSA-7fj2-8x79-rjf4, UBUNTU-CVE-2023-0567, USN-6053-1

## What is CVE-2023-0567?

CVE-2023-0567 is a high-severity authentication bypass vulnerability in Php Php, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, password_verify() function may accept some invalid Blowfish hashes as valid. If such invalid hash ever ends up in the password database, it may lead to an application allowing any password for this entry as valid.

Weakness: CWE-916 (Use of Password Hash With Insufficient Computational Effort)

## Which versions are affected by CVE-2023-0567?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |
| `php` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |
| `php-min` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |

Products: Php Php.

## How do I fix CVE-2023-0567?

Upgrade libphp to a fixed version for your release line: 8.0.28, 8.1.16 or 8.2.3.

## Is CVE-2023-0567 being exploited?

There is no known exploitation of CVE-2023-0567 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0567 and fix it if it is affected.

What it is: CVE-2023-0567 is a high-severity authentication bypass vulnerability in Php Php, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0567 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3
- php (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3
- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0567/ (Markdown: https://insights.sbomify.com/CVE-2023-0567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0567
- OSV: https://osv.dev/vulnerability/CVE-2023-0567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0567/
Summaries are generated and may contain mistakes; the official description above is the record.
