# CVE-2023-0568: Array overrun in common path resolve code

> An array overrun in PHP's path resolution allows attackers to overwrite adjacent memory, potentially leading to unauthorized data access or modification.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** AZL-13587, AZL-63073, BIT-libphp-2023-0568, BIT-php-2023-0568, BIT-php-min-2023-0568, CLSA-2024-1734542452, DEBIAN-CVE-2023-0568, ECHO-61e4-17e4-60bd, GHSA-6gqv-38q3-6c47, UBUNTU-CVE-2023-0568

## What is CVE-2023-0568?

CVE-2023-0568 is a high-severity memory corruption vulnerability in Php Php, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, core path resolution function allocate buffer one byte too small. When resolving paths with lengths close to system MAXPATHLEN setting, this may lead to the byte after the allocated buffer being overwritten with NUL value, which might lead to unauthorized data access or modification.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2023-0568?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |
| `php` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |
| `php-min` | Bitnami | From 8.0.0 | 8.0.28, 8.1.16, 8.2.3 |

Products: Php Php.

## How do I fix CVE-2023-0568?

Upgrade libphp to a fixed version for your release line: 8.0.28, 8.1.16 or 8.2.3.

## Is CVE-2023-0568 being exploited?

There is no known exploitation of CVE-2023-0568 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0568 and fix it if it is affected.

What it is: CVE-2023-0568 is a high-severity memory corruption vulnerability in Php Php, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0568 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3
- php (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3
- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.28, 8.1.16, 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0568/ (Markdown: https://insights.sbomify.com/CVE-2023-0568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0568
- OSV: https://osv.dev/vulnerability/CVE-2023-0568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0568/
Summaries are generated and may contain mistakes; the official description above is the record.
