{"answers":{"affected":"3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0569 exists.","fix":"Upgrade publify_core to 9.2.10 or later.","what":"CVE-2023-0569 is a high-severity vulnerability in publify/publify, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-0569 and fix it if it is affected.\n\nWhat it is: CVE-2023-0569 is a high-severity vulnerability in publify/publify, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0569 exists.\n\nAffected packages and fixed versions:\n- publify_core (RubyGems): affected all versions; fixed in 9.2.10\n- publify_core (RubyGems): affected all versions; fixed in 9.2.10\n- publify (Bitnami): affected all versions; fixed in 9.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0569/ (Markdown: https://insights.sbomify.com/CVE-2023-0569/index.md)","id":"CVE-2023-0569","markdown":"https://insights.sbomify.com/CVE-2023-0569/index.md","name":"CVE-2023-0569","record":{"aliases":["BIT-publify-2023-0569","GHSA-g7gf-2rqw-5rwx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Publify blog engine","requires_auth":"none","summary":"Publify allows weak passwords, potentially enabling attackers to guess credentials and take over user accounts.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"publify","vendor":"publify_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Weak Password Requirements in publify/publify","id":"CVE-2023-0569","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"SourceCodester Online Tours \u0026 Travels Management System payment_operation.php sql injection","id":"CVE-2023-0570"},"packages":[{"ecosystem":"Bitnami","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify","purl":"pkg:bitnami/publify","source":"BIT-publify-2023-0569"},{"ecosystem":"RubyGems","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":null,"source":"GHSA-g7gf-2rqw-5rwx"},{"ecosystem":"RubyGems","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":"pkg:gem/publify_core","source":"GHSA-g7gf-2rqw-5rwx"}],"prev":{"headline":"Array overrun in common path resolve code","id":"CVE-2023-0568"},"products":["publify/publify"],"published":"2023-01-29","related":[{"cvss_score":9.9,"headline":"Authorization Bypass Through User-Controlled Key in publify/publify","id":"CVE-2022-1810","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":9.1,"headline":"Unrestricted Upload of File with Dangerous Type in publify/publify","id":"CVE-2022-1811","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":8.8,"headline":"Leaking password protected articles content due to improper access control in publify/publify","id":"CVE-2022-1553","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":8.4,"headline":"Improper Input Validation in publify/publify","id":"CVE-2023-0299","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":7.6,"headline":"Integer Overflow or Wraparound in publify/publify","id":"CVE-2022-1812","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":6.5,"headline":"Business Logic Errors in publify/publify","id":"CVE-2022-0524","kev_date_added":null,"published":"2022-02-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-28","vendors":["publify"]},"summary":"Publify allows weak passwords, potentially enabling attackers to guess credentials and take over user accounts.","url":"https://insights.sbomify.com/CVE-2023-0569/"}