# CVE-2023-0569: Weak Password Requirements in publify/publify

> Publify allows weak passwords, potentially enabling attackers to guess credentials and take over user accounts.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2023
- **Updated:** 28 Mar 2025
- **Also known as:** BIT-publify-2023-0569, GHSA-g7gf-2rqw-5rwx

## What is CVE-2023-0569?

CVE-2023-0569 is a high-severity vulnerability in publify/publify, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2023-0569?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify` | Bitnami | All versions | 9.2.10 |

Products: Publify Project Publify.

## How do I fix CVE-2023-0569?

Upgrade publify_core to 9.2.10 or later.

## Is CVE-2023-0569 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0569 exists.

## Other vulnerabilities in publify/publify

- [CVE-2022-1810](https://insights.sbomify.com/CVE-2022-1810/): Authorization Bypass Through User-Controlled Key in publify/publify (critical 9.9)
- [CVE-2022-1811](https://insights.sbomify.com/CVE-2022-1811/): Unrestricted Upload of File with Dangerous Type in publify/publify (critical 9.1)
- [CVE-2022-1553](https://insights.sbomify.com/CVE-2022-1553/): Leaking password protected articles content due to improper access control in publify/publify (high 8.8)
- [CVE-2023-0299](https://insights.sbomify.com/CVE-2023-0299/): Improper Input Validation in publify/publify (high 8.4)
- [CVE-2022-1812](https://insights.sbomify.com/CVE-2022-1812/): Integer Overflow or Wraparound in publify/publify (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0569 and fix it if it is affected.

What it is: CVE-2023-0569 is a high-severity vulnerability in publify/publify, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0569 exists.

Affected packages and fixed versions:
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify (Bitnami): affected all versions; fixed in 9.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0569/ (Markdown: https://insights.sbomify.com/CVE-2023-0569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0569
- OSV: https://osv.dev/vulnerability/CVE-2023-0569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0569/
Summaries are generated and may contain mistakes; the official description above is the record.
