# CVE-2023-0583: VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update

> Authenticated contributors can modify VK Blocks plugin settings due to missing authorization checks in the REST API.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jun 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-xrr2-rr4f-w9p3

## What is CVE-2023-0583?

CVE-2023-0583 is a medium-severity missing authorization vulnerability in vektor-inc VK Blocks, published on 3 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_vk_blocks_options' function in versions up to, and including, 1.57.0.5. This allows authenticated attackers, with contributor-level permissions or above, to change plugin settings including default icons.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-0583?

It affects 1 product.


Products: Vektor-Inc Vk Blocks.

## How do I fix CVE-2023-0583?

No fix has been published for CVE-2023-0583 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-0583 being exploited?

There is no known exploitation of CVE-2023-0583 in the wild and no public exploit code.

## Other vulnerabilities in vektor-inc VK Blocks

- [CVE-2023-5706](https://insights.sbomify.com/CVE-2023-5706/): VK Blocks <= 1.63.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block (medium 6.4)
- [CVE-2023-27923](https://insights.sbomify.com/CVE-2023-27923/): Cross-site scripting in VK Blocks and VK Blocks Pro (medium 5.4)
- [CVE-2023-27925](https://insights.sbomify.com/CVE-2023-27925/): Cross-site scripting in VK Blocks and VK Blocks Pro (medium 5.4)
- [CVE-2023-0584](https://insights.sbomify.com/CVE-2023-0584/): VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0583 and fix it if it is affected.

What it is: CVE-2023-0583 is a medium-severity missing authorization vulnerability in vektor-inc VK Blocks, published on 3 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0583 in the wild and no public exploit code.

Affected product: vektor-inc VK Blocks. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0583/ (Markdown: https://insights.sbomify.com/CVE-2023-0583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0583
- OSV: https://osv.dev/vulnerability/CVE-2023-0583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0583/
Summaries are generated and may contain mistakes; the official description above is the record.
