# CVE-2023-0591: Path Traversal in ubi_reader

> Attackers can overwrite arbitrary files outside the extraction directory by crafting malicious UBIFS files processed by ubi_reader.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jan 2023
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-vp2x-3mc3-3cj4, PYSEC-2023-51

## What is CVE-2023-0591?

CVE-2023-0591 is a medium-severity path traversal vulnerability in ubi_reader, published on 31 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ubireader_extract_files is vulnerable to path traversal when run against specifically crafted UBIFS files, allowing the attacker to overwrite files outside of the extraction directory (provided the process has write access to that file or directory).

This is due to the fact that a node name (dent_node.name) is considered trusted and joined to the extraction directory path during processing, then the node content is written to that joined path. By crafting a malicious UBIFS file with node names holding path traversal payloads (e.g. ../../tmp/outside.txt), it's possible to force ubi_reader to write outside of the extraction directory.

This issue affects ubi-reader before 0.8.5.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-0591?

3 open source packages ship an affected version, including ubi-reader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ubi-reader` | PyPI | All versions | 0.8.5 |
| `ubi-reader` | PyPI | All versions | 0.8.5 |
| `ubi-reader` | PyPI | All versions | 0.8.5 |

Products: Ubi Reader Project Ubi Reader.

## How do I fix CVE-2023-0591?

Upgrade ubi-reader to 0.8.5 or later.

## Is CVE-2023-0591 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0591 exists.

## Other vulnerabilities in ubi_reader

- [CVE-2022-4572](https://insights.sbomify.com/CVE-2022-4572/): UBI Reader UBIFS File output.py ubireader_extract_files path traversal (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0591 and fix it if it is affected.

What it is: CVE-2023-0591 is a medium-severity path traversal vulnerability in ubi_reader, published on 31 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0591 exists.

Affected packages and fixed versions:
- ubi-reader (PyPI): affected all versions; fixed in 0.8.5
- ubi-reader (PyPI): affected all versions; fixed in 0.8.5
- ubi-reader (PyPI): affected all versions; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0591/ (Markdown: https://insights.sbomify.com/CVE-2023-0591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0591
- OSV: https://osv.dev/vulnerability/CVE-2023-0591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0591/
Summaries are generated and may contain mistakes; the official description above is the record.
