{"answers":{"affected":"2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0609 exists.","fix":"Upgrade wallabag/wallabag to 2.5.3 or later.","what":"CVE-2023-0609 is a medium-severity missing authorization vulnerability in wallabag/wallabag, published on 1 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-0609 and fix it if it is affected.\n\nWhat it is: CVE-2023-0609 is a medium-severity missing authorization vulnerability in wallabag/wallabag, published on 1 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0609 exists.\n\nAffected packages and fixed versions:\n- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.5.3\n- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0609/ (Markdown: https://insights.sbomify.com/CVE-2023-0609/index.md)","id":"CVE-2023-0609","markdown":"https://insights.sbomify.com/CVE-2023-0609/index.md","name":"CVE-2023-0609","record":{"aliases":["GHSA-qwx8-mxxx-mg96"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"wallabag web application","requires_auth":"low_privilege","summary":"An attacker can access or modify data without proper authorization in the wallabag web application.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"wallabag","vendor":"wallabag"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0610"},"packages":[{"ecosystem":"Packagist","fixed":["2.5.3"],"introduced":["2.0.0-alpha.1"],"last_affected":[],"package":"wallabag/wallabag","purl":null,"source":"GHSA-qwx8-mxxx-mg96"},{"ecosystem":"Packagist","fixed":["2.5.3"],"introduced":["2.0.0-alpha.1"],"last_affected":[],"package":"wallabag/wallabag","purl":"pkg:composer/wallabag/wallabag","source":"GHSA-qwx8-mxxx-mg96"}],"prev":{"headline":"Cross-site Scripting (XSS) - DOM in microweber/microweber","id":"CVE-2023-0608"},"products":["wallabag/wallabag"],"published":"2023-02-01","related":[{"cvss_score":7.3,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0734","kev_date_added":null,"published":"2023-03-05"},{"cvss_score":6.5,"headline":"CSRF in wallabag/wallabag","id":"CVE-2023-0737","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-4455","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-0735","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":5.4,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0610","kev_date_added":null,"published":"2023-02-01"},{"cvss_score":4.6,"headline":"Cross-site Scripting (XSS) - Stored in wallabag/wallabag","id":"CVE-2023-0736","kev_date_added":null,"published":"2023-02-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-26","vendors":["wallabag"]},"summary":"An attacker can access or modify data without proper authorization in the wallabag web application.","url":"https://insights.sbomify.com/CVE-2023-0609/"}