# CVE-2023-0610: Improper Authorization in wallabag/wallabag

> An attacker can access or modify data without proper authorization in the wallabag web application.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2023
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-mrqx-mjc4-vfh3

## What is CVE-2023-0610?

CVE-2023-0610 is a medium-severity missing authorization vulnerability in wallabag/wallabag, published on 1 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-0610?

2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wallabag/wallabag` | Packagist | From 2.0.0-beta.1 | 2.5.3 |
| `wallabag/wallabag` | Packagist | From 2.0.0-beta.1 | 2.5.3 |

Products: Wallabag Wallabag.

## How do I fix CVE-2023-0610?

Upgrade wallabag/wallabag to 2.5.3 or later.

## Is CVE-2023-0610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0610 exists.

## Other vulnerabilities in wallabag/wallabag

- [CVE-2023-0734](https://insights.sbomify.com/CVE-2023-0734/): Improper Authorization in wallabag/wallabag (high 7.3)
- [CVE-2023-0737](https://insights.sbomify.com/CVE-2023-0737/): CSRF in wallabag/wallabag (medium 6.5)
- [CVE-2023-4455](https://insights.sbomify.com/CVE-2023-4455/): Cross-Site Request Forgery (CSRF) in wallabag/wallabag (medium 6.5)
- [CVE-2023-0735](https://insights.sbomify.com/CVE-2023-0735/): Cross-Site Request Forgery (CSRF) in wallabag/wallabag (medium 6.5)
- [CVE-2023-0609](https://insights.sbomify.com/CVE-2023-0609/): Improper Authorization in wallabag/wallabag (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0610 and fix it if it is affected.

What it is: CVE-2023-0610 is a medium-severity missing authorization vulnerability in wallabag/wallabag, published on 1 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0610 exists.

Affected packages and fixed versions:
- wallabag/wallabag (Packagist): affected from 2.0.0-beta.1; fixed in 2.5.3
- wallabag/wallabag (Packagist): affected from 2.0.0-beta.1; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0610/ (Markdown: https://insights.sbomify.com/CVE-2023-0610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0610
- OSV: https://osv.dev/vulnerability/CVE-2023-0610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0610/
Summaries are generated and may contain mistakes; the official description above is the record.
