# CVE-2023-0620: Vault Vulnerable to SQL Injection When Configuring the Microsoft SQL Database Storage Backend

> Attackers can execute malicious SQL commands via unsanitized parameters in the MSSQL storage backend configuration, requiring an upgrade to patched versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-vault-2023-0620, GHSA-v3hp-mcj5-pg39, GO-2023-1685

## What is CVE-2023-0620?

CVE-2023-0620 is a medium-severity SQL injection vulnerability in Hashicorp Vault, published on 30 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

HashiCorp Vault and Vault Enterprise versions 0.8.0 through 1.13.1 are vulnerable to an SQL injection attack when configuring the Microsoft SQL (MSSQL) Database Storage Backend. When configuring the MSSQL plugin through the local, certain parameters are not sanitized when passed to the user-provided MSSQL database. An attacker may modify these parameters to execute a malicious SQL command.

This issue is fixed in versions 1.13.1, 1.12.5, and 1.11.9.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-0620?

8 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 0.8.0 | 1.11.9, 1.12.5, 1.13.1 |
| `github.com/hashicorp/vault` | Go | From 0.8.0 | 1.11.9 |
| `github.com/hashicorp/vault` | Go | From 0.8.0 | 1.11.9 |
| `github.com/hashicorp/vault` | Go | From 1.12.0 | 1.12.5 |
| `github.com/hashicorp/vault` | Go | From 1.12.0 | 1.12.5 |
| `github.com/hashicorp/vault` | Go | From 1.13.0 | 1.13.1 |
| `github.com/hashicorp/vault` | Go | From 1.13.0 | 1.13.1 |
| `vault` | Bitnami | All versions | 1.11.9, 1.12.5, 1.13.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2023-0620?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.11.9, 1.12.5 or 1.13.1.

## Is CVE-2023-0620 being exploited?

There is no known exploitation of CVE-2023-0620 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0620 and fix it if it is affected.

What it is: CVE-2023-0620 is a medium-severity SQL injection vulnerability in Hashicorp Vault, published on 30 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0620 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 0.8.0; fixed in 1.11.9, 1.12.5, 1.13.1
- github.com/hashicorp/vault (Go): affected from 0.8.0; fixed in 1.11.9
- github.com/hashicorp/vault (Go): affected from 0.8.0; fixed in 1.11.9
- github.com/hashicorp/vault (Go): affected from 1.12.0; fixed in 1.12.5
- github.com/hashicorp/vault (Go): affected from 1.12.0; fixed in 1.12.5
- github.com/hashicorp/vault (Go): affected from 1.13.0; fixed in 1.13.1
- github.com/hashicorp/vault (Go): affected from 1.13.0; fixed in 1.13.1
- vault (Bitnami): affected all versions; fixed in 1.11.9, 1.12.5, 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0620/ (Markdown: https://insights.sbomify.com/CVE-2023-0620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0620
- OSV: https://osv.dev/vulnerability/CVE-2023-0620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0620/
Summaries are generated and may contain mistakes; the official description above is the record.
