CVE-2023-0650 YAFNET Signature cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts via the Signature Handler in YAFNET, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2023-0650?

CVE-2023-0650 is a low-severity cross-site scripting vulnerability in YAFNET, published on 2 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in YAFNET up to 3.1.11 and classified as problematic. This issue affects some unknown processing of the component Signature Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.12 is able to address this issue. The identifier of the patch is a1442a2bacc3335461b44c250e81f8d99c60735f. It is recommended to upgrade the affected component. The identifier VDB-220037 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2023-0650?

It affects 1 product.

Products include Yetanotherforum Yaf.net.

How do I fix CVE-2023-0650?

No fix has been published for CVE-2023-0650 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-0650 being exploited?

There is no known exploitation of CVE-2023-0650 in the wild and no public exploit code.

Sources

Also known as GHSA-mg6p-jjff-7g5m, GHSA-mvrc-wwg3-6rfm.

Is CVE-2023-0650 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free