# CVE-2023-0735: Cross-Site Request Forgery (CSRF) in wallabag/wallabag

> Attackers can trick authenticated users into performing unwanted actions in wallabag, potentially modifying data.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-2qxp-xmx6-cq4f

## What is CVE-2023-0735?

CVE-2023-0735 is a medium-severity vulnerability in wallabag/wallabag, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) in GitHub repository wallabag/wallabag prior to 2.5.4.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-0735?

2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wallabag/wallabag` | Packagist | All versions | 2.5.4 |
| `wallabag/wallabag` | Packagist | All versions | 2.5.4 |

Products: Wallabag Wallabag.

## How do I fix CVE-2023-0735?

Upgrade wallabag/wallabag to 2.5.4 or later.

## Is CVE-2023-0735 being exploited?

There is no known exploitation of CVE-2023-0735 in the wild and no public exploit code.

## Other vulnerabilities in wallabag/wallabag

- [CVE-2023-0734](https://insights.sbomify.com/CVE-2023-0734/): Improper Authorization in wallabag/wallabag (high 7.3)
- [CVE-2023-0737](https://insights.sbomify.com/CVE-2023-0737/): CSRF in wallabag/wallabag (medium 6.5)
- [CVE-2023-4455](https://insights.sbomify.com/CVE-2023-4455/): Cross-Site Request Forgery (CSRF) in wallabag/wallabag (medium 6.5)
- [CVE-2023-0609](https://insights.sbomify.com/CVE-2023-0609/): Improper Authorization in wallabag/wallabag (medium 6.5)
- [CVE-2023-0610](https://insights.sbomify.com/CVE-2023-0610/): Improper Authorization in wallabag/wallabag (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0735 and fix it if it is affected.

What it is: CVE-2023-0735 is a medium-severity vulnerability in wallabag/wallabag, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0735 in the wild and no public exploit code.

Affected packages and fixed versions:
- wallabag/wallabag (Packagist): affected all versions; fixed in 2.5.4
- wallabag/wallabag (Packagist): affected all versions; fixed in 2.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0735/ (Markdown: https://insights.sbomify.com/CVE-2023-0735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0735
- OSV: https://osv.dev/vulnerability/CVE-2023-0735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0735/
Summaries are generated and may contain mistakes; the official description above is the record.
