CVE-2023-0737 CSRF in wallabag/wallabag

Medium 6.5 Published Updated

Attackers can delete user accounts via CSRF in wallabag, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-0737?

CVE-2023-0737 is a medium-severity vulnerability in wallabag/wallabag, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

wallabag version 2.5.2 contains a Cross-Site Request Forgery (CSRF) vulnerability that allows attackers to arbitrarily delete user accounts via the /account/delete endpoint. This issue is fixed in version 2.5.4.

Weakness: CWE-352

Which versions are affected by CVE-2023-0737?

2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.

PackageAffectedFixed in
wallabag/wallabag PackagistAll versions2.5.4
wallabag/wallabag PackagistAll versions2.5.4

Products include Wallabag Wallabag.

How do I fix CVE-2023-0737?

Upgrade wallabag/wallabag to 2.5.4 or later.

Is CVE-2023-0737 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0737 exists.

Sources

Also known as GHSA-99w8-c5f6-96pp.

Is CVE-2023-0737 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free