{"answers":{"affected":"2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0737 exists.","fix":"Upgrade wallabag/wallabag to 2.5.4 or later.","what":"CVE-2023-0737 is a medium-severity vulnerability in wallabag/wallabag, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-0737 and fix it if it is affected.\n\nWhat it is: CVE-2023-0737 is a medium-severity vulnerability in wallabag/wallabag, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0737 exists.\n\nAffected packages and fixed versions:\n- wallabag/wallabag (Packagist): affected all versions; fixed in 2.5.4\n- wallabag/wallabag (Packagist): affected all versions; fixed in 2.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0737/ (Markdown: https://insights.sbomify.com/CVE-2023-0737/index.md)","id":"CVE-2023-0737","markdown":"https://insights.sbomify.com/CVE-2023-0737/index.md","name":"CVE-2023-0737","record":{"aliases":["GHSA-99w8-c5f6-96pp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"wallabag web application","requires_auth":"none","summary":"Attackers can delete user accounts via CSRF in wallabag, requiring an upgrade to the latest version.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"wallabag","vendor":"wallabag"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"wallabag version 2.5.2 contains a Cross-Site Request Forgery (CSRF) vulnerability that allows attackers to arbitrarily delete user accounts via the /account/delete endpoint. This issue is fixed in version 2.5.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CSRF in wallabag/wallabag","id":"CVE-2023-0737","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in OrangeScrum","id":"CVE-2023-0738"},"packages":[{"ecosystem":"Packagist","fixed":["2.5.4"],"introduced":["0"],"last_affected":[],"package":"wallabag/wallabag","purl":null,"source":"GHSA-99w8-c5f6-96pp"},{"ecosystem":"Packagist","fixed":["2.5.4"],"introduced":["0"],"last_affected":[],"package":"wallabag/wallabag","purl":"pkg:composer/wallabag/wallabag","source":"GHSA-99w8-c5f6-96pp"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in wallabag/wallabag","id":"CVE-2023-0736"},"products":["wallabag/wallabag"],"published":"2024-11-15","related":[{"cvss_score":7.3,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0734","kev_date_added":null,"published":"2023-03-05"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-4455","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-0735","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":6.5,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0609","kev_date_added":null,"published":"2023-02-01"},{"cvss_score":5.4,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0610","kev_date_added":null,"published":"2023-02-01"},{"cvss_score":4.6,"headline":"Cross-site Scripting (XSS) - Stored in wallabag/wallabag","id":"CVE-2023-0736","kev_date_added":null,"published":"2023-02-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-20","vendors":["wallabag"]},"summary":"Attackers can delete user accounts via CSRF in wallabag, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-0737/"}