# CVE-2023-0739: Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in answerdev/answer

> A race condition in the Answer Q&A platform allows concurrent execution issues, potentially leading to data integrity problems or unexpected behavior.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-qx34-47fc-vv79, GO-2023-1553

## What is CVE-2023-0739?

CVE-2023-0739 is a high-severity vulnerability in answerdev/answer, published on 8 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in GitHub repository answerdev/answer prior to 1.0.4.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2023-0739?

3 open source packages ship an affected version, including github.com/answerdev/answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/answerdev/answer` | Go | All versions | 1.0.4 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.4 |
| `github.com/answerdev/answer` | Go | All versions | 1.0.4 |

Products: Answer Answer.

## How do I fix CVE-2023-0739?

Upgrade github.com/answerdev/answer to 1.0.4 or later.

## Is CVE-2023-0739 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0739 exists.

## Other vulnerabilities in answerdev/answer

- [CVE-2023-0744](https://insights.sbomify.com/CVE-2023-0744/): Improper Access Control in answerdev/answer (critical 9.8)
- [CVE-2023-1244](https://insights.sbomify.com/CVE-2023-1244/): Cross-site Scripting (XSS) - Stored in answerdev/answer (critical 9.3)
- [CVE-2023-4125](https://insights.sbomify.com/CVE-2023-4125/): Weak Password Requirements in answerdev/answer (high 8.8)
- [CVE-2023-1241](https://insights.sbomify.com/CVE-2023-1241/): Cross-site Scripting (XSS) - Stored in answerdev/answer (high 8.8)
- [CVE-2023-4815](https://insights.sbomify.com/CVE-2023-4815/): Missing Authentication for Critical Function in answerdev/answer (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0739 and fix it if it is affected.

What it is: CVE-2023-0739 is a high-severity vulnerability in answerdev/answer, published on 8 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0739 exists.

Affected packages and fixed versions:
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.4
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.4
- github.com/answerdev/answer (Go): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0739/ (Markdown: https://insights.sbomify.com/CVE-2023-0739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0739
- OSV: https://osv.dev/vulnerability/CVE-2023-0739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0739/
Summaries are generated and may contain mistakes; the official description above is the record.
