{"answers":{"affected":"2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0790 exists.","fix":"Upgrade thorsten/phpmyfaq to 3.1.11 or later.","what":"CVE-2023-0790 is a high-severity denial of service vulnerability in Phpmyfaq Phpmyfaq, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-0790 and fix it if it is affected.\n\nWhat it is: CVE-2023-0790 is a high-severity denial of service vulnerability in Phpmyfaq Phpmyfaq, published on 12 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-0790 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.11\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0790/ (Markdown: https://insights.sbomify.com/CVE-2023-0790/index.md)","id":"CVE-2023-0790","markdown":"https://insights.sbomify.com/CVE-2023-0790/index.md","name":"CVE-2023-0790","record":{"aliases":["GHSA-6vv4-qq3r-9rv8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"low_privilege","summary":"An uncaught exception in phpMyFAQ allows attackers to cause a denial of service condition.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Uncaught Exception in GitHub repository thorsten/phpmyfaq prior to 3.1.11.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uncaught Exception in thorsten/phpmyfaq","id":"CVE-2023-0790","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0791"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.11"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-6vv4-qq3r-9rv8"},{"ecosystem":"Packagist","fixed":["3.1.11"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-6vv4-qq3r-9rv8"}],"prev":{"headline":"Command Injection in thorsten/phpmyfaq","id":"CVE-2023-0789"},"products":["thorsten/phpmyfaq"],"published":"2023-02-12","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["thorsten"]},"summary":"An uncaught exception in phpMyFAQ allows attackers to cause a denial of service condition.","url":"https://insights.sbomify.com/CVE-2023-0790/"}