# CVE-2023-0815: Plaintext Password Present in the Web logs

> Attackers can read plaintext credentials from logs if debug logging is enabled in OpenNMS Meridian or Horizon.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2023
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-9xpj-mvp2-3943

## What is CVE-2023-0815?

CVE-2023-0815 is a medium-severity vulnerability in The OpenNMS Group Horizon, published on 23 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Potential Insertion of Sensitive Information into Jetty Log Files in multiple versions of OpenNMS Meridian and Horizon could allow disclosure of usernames and passwords if the logging level is set to debug. Users
should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and
Horizon installation instructions state that they are intended for installation
within an organization's private networks and should not be directly accessible
from the Internet.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-0815?

2 open source packages ship an affected version, including org.opennms:opennms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms` | Maven | All versions | 31.0.4 |
| `org.opennms:opennms` | Maven | All versions | 31.0.4 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2023-0815?

Upgrade org.opennms:opennms to 31.0.4 or later.

## Is CVE-2023-0815 being exploited?

There is no known exploitation of CVE-2023-0815 in the wild and no public exploit code.

## Other vulnerabilities in The OpenNMS Group Horizon

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0815 and fix it if it is affected.

What it is: CVE-2023-0815 is a medium-severity vulnerability in The OpenNMS Group Horizon, published on 23 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0815 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opennms:opennms (Maven): affected all versions; fixed in 31.0.4
- org.opennms:opennms (Maven): affected all versions; fixed in 31.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0815/ (Markdown: https://insights.sbomify.com/CVE-2023-0815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0815
- OSV: https://osv.dev/vulnerability/CVE-2023-0815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0815/
Summaries are generated and may contain mistakes; the official description above is the record.
