CVE-2023-0821 Nomad Client Vulnerable to Decompression Bombs in Artifact Block

Medium 6.5 Published Updated

Attackers can cause excessive disk usage and denial of service in HashiCorp Nomad by submitting maliciously compressed artifact sources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-0821?

CVE-2023-0821 is a medium-severity denial of service vulnerability in HashiCorp Nomad, published on 16 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

HashiCorp Nomad and Nomad Enterprise 1.2.15 up to 1.3.8, and 1.4.3 jobs using a maliciously compressed artifact stanza source can cause excessive disk usage. Fixed in 1.2.16, 1.3.9, and 1.4.4.

Weakness: CWE-409

Which versions are affected by CVE-2023-0821?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoFrom 1.2.151.2.16, 1.3.9, 1.4.4
github.com/hashicorp/nomad GoFrom 1.2.151.2.16
github.com/hashicorp/nomad GoFrom 1.2.151.2.16
github.com/hashicorp/nomad GoFrom 1.3.01.3.9
github.com/hashicorp/nomad GoFrom 1.3.01.3.9
github.com/hashicorp/nomad GoFrom 1.4.01.4.4
1 more packages
github.com/hashicorp/nomad GoFrom 1.4.01.4.4

Products include Hashicorp Nomad.

How do I fix CVE-2023-0821?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.2.16, 1.3.9 or 1.4.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-0821 being exploited?

There is no known exploitation of CVE-2023-0821 in the wild and no public exploit code.

Sources

Also known as GHSA-w479-w22g-cffh, GO-2023-1581, UBUNTU-CVE-2023-0821.

Is CVE-2023-0821 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free