# CVE-2023-0821: Nomad Client Vulnerable to Decompression Bombs in Artifact Block

> Attackers can cause excessive disk usage and denial of service in HashiCorp Nomad by submitting maliciously compressed artifact sources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-w479-w22g-cffh, GO-2023-1581, UBUNTU-CVE-2023-0821

## What is CVE-2023-0821?

CVE-2023-0821 is a medium-severity denial of service vulnerability in HashiCorp Nomad, published on 16 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise 1.2.15 up to 1.3.8, and 1.4.3 jobs using a maliciously compressed artifact stanza source can cause excessive disk usage. Fixed in 1.2.16, 1.3.9, and 1.4.4.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2023-0821?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 1.2.15 | 1.2.16, 1.3.9, 1.4.4 |
| `github.com/hashicorp/nomad` | Go | From 1.2.15 | 1.2.16 |
| `github.com/hashicorp/nomad` | Go | From 1.2.15 | 1.2.16 |
| `github.com/hashicorp/nomad` | Go | From 1.3.0 | 1.3.9 |
| `github.com/hashicorp/nomad` | Go | From 1.3.0 | 1.3.9 |
| `github.com/hashicorp/nomad` | Go | From 1.4.0 | 1.4.4 |
| `github.com/hashicorp/nomad` | Go | From 1.4.0 | 1.4.4 |

Products: Hashicorp Nomad.

## How do I fix CVE-2023-0821?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.2.16, 1.3.9 or 1.4.4.

## Is CVE-2023-0821 being exploited?

There is no known exploitation of CVE-2023-0821 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0821 and fix it if it is affected.

What it is: CVE-2023-0821 is a medium-severity denial of service vulnerability in HashiCorp Nomad, published on 16 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0821 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 1.2.15; fixed in 1.2.16, 1.3.9, 1.4.4
- github.com/hashicorp/nomad (Go): affected from 1.2.15; fixed in 1.2.16
- github.com/hashicorp/nomad (Go): affected from 1.2.15; fixed in 1.2.16
- github.com/hashicorp/nomad (Go): affected from 1.3.0; fixed in 1.3.9
- github.com/hashicorp/nomad (Go): affected from 1.3.0; fixed in 1.3.9
- github.com/hashicorp/nomad (Go): affected from 1.4.0; fixed in 1.4.4
- github.com/hashicorp/nomad (Go): affected from 1.4.0; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0821/ (Markdown: https://insights.sbomify.com/CVE-2023-0821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0821
- OSV: https://osv.dev/vulnerability/CVE-2023-0821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0821/
Summaries are generated and may contain mistakes; the official description above is the record.
