# CVE-2023-0824: UserPlus <= 2.0 - Stored XSS via CSRF

> Attackers can inject stored XSS payloads via CSRF, allowing execution of malicious scripts in admin sessions.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-hrmh-j687-fg6h

## What is CVE-2023-0824?

CVE-2023-0824 is a high-severity cross-site scripting vulnerability in Unknown User registration & user profile, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The User registration & user profile WordPress plugin through 2.0 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged-in admin add Stored XSS payloads via a CSRF attack.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-0824?

It affects 1 product.


Products: Wpuserplus Userplus.

## How do I fix CVE-2023-0824?

No fix has been published for CVE-2023-0824 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-0824 being exploited?

There is no known exploitation of CVE-2023-0824 in the wild and no public exploit code.

## Other vulnerabilities in Unknown User registration & user profile

- [CVE-2024-9518](https://insights.sbomify.com/CVE-2024-9518/): UserPlus <= 2.0 - Unauthenticated Privilege Escalation (critical 9.8)
- [CVE-2024-9519](https://insights.sbomify.com/CVE-2024-9519/): UserPlus <= 2.0 - Authenticated (Editor+) Registration Form Update to Privilege Escalation (high 7.2)
- [CVE-2024-9520](https://insights.sbomify.com/CVE-2024-9520/): UserPlus <= 2.0 - Missing Authorization via Multiple Functions (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0824 and fix it if it is affected.

What it is: CVE-2023-0824 is a high-severity cross-site scripting vulnerability in Unknown User registration & user profile, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0824 in the wild and no public exploit code.

Affected product: Unknown User registration & user profile. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0824/ (Markdown: https://insights.sbomify.com/CVE-2023-0824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0824
- OSV: https://osv.dev/vulnerability/CVE-2023-0824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0824/
Summaries are generated and may contain mistakes; the official description above is the record.
