# CVE-2023-0836: Information disclosure in HAProxy

> An attacker can read uninitialized memory from HAProxy connection buffers, potentially disclosing sensitive data to FastCGI backends.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** ALSA-2023:6496, BIT-haproxy-2023-0836, CLSA-2025-1736284126, DEBIAN-CVE-2023-0836, DSA-5388-1, GHSA-xhfw-qhxr-hjhq, RHSA-2023:6496, UBUNTU-CVE-2023-0836, USN-5994-1

## What is CVE-2023-0836?

CVE-2023-0836 is a high-severity vulnerability in HAProxy, published on 29 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An information leak vulnerability was discovered in HAProxy 2.1, 2.2 before 2.2.27, 2.3, 2.4 before 2.4.21, 2.5 before 2.5.11, 2.6 before 2.6.8, 2.7 before 2.7.1. There are 5 bytes left uninitialized in the connection buffer when encoding the FCGI_BEGIN_REQUEST record. Sensitive data may be disclosed to configured FastCGI backends in an unexpected way.

Weakness: CWE-459 (Incomplete Cleanup), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-0836?

1 open source package ship an affected version, including haproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.1.0 | 2.1.1, 2.2.27, 2.3.1, 2.4.22, 2.5.12, 2.6.9, 2.7.1 |
| `haproxy` | AlmaLinux:9 | All versions | 2.4.22-1.el9 |
| `haproxy` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.4.22-1.el9 |
| `haproxy-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.4.22-1.el9 |
| `haproxy-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.4.22-1.el9 |

Products: Haproxy Haproxy.

## How do I fix CVE-2023-0836?

Upgrade haproxy to a fixed version for your release line: 2.1.1, 2.2.27, 2.3.1 or 2.4.22.

## Is CVE-2023-0836 being exploited?

There is no known exploitation of CVE-2023-0836 in the wild and no public exploit code.

## Other vulnerabilities in HAProxy

- [CVE-2026-55203](https://insights.sbomify.com/CVE-2026-55203/): HAProxy - Integer Overflow in FCGI Demux Record Length Field (critical 9.0)
- [CVE-2026-55204](https://insights.sbomify.com/CVE-2026-55204/): HAProxy - NULL Pointer Dereference in hpack_dht_insert Function (high 8.7)
- [CVE-2023-45539](https://insights.sbomify.com/CVE-2023-45539/): Information disclosure in n/a (high 8.2)
- [CVE-2024-45506](https://insights.sbomify.com/CVE-2024-45506/): Denial of service in n/a (high 7.5)
- [CVE-2019-18277](https://insights.sbomify.com/CVE-2019-18277/): Other in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0836 and fix it if it is affected.

What it is: CVE-2023-0836 is a high-severity vulnerability in HAProxy, published on 29 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-0836 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.1.0; fixed in 2.1.1, 2.2.27, 2.3.1, 2.4.22, 2.5.12, 2.6.9, 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0836/ (Markdown: https://insights.sbomify.com/CVE-2023-0836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0836
- OSV: https://osv.dev/vulnerability/CVE-2023-0836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0836/
Summaries are generated and may contain mistakes; the official description above is the record.
