CVE-2023-0870 Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)

High 8.1 Published Updated

Attackers can manipulate forms via CSRF to access confidential information and compromise integrity in OpenNMS Meridian and Horizon.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-0870?

CVE-2023-0870 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Weakness: CWE-352

Which versions are affected by CVE-2023-0870?

2 open source packages ship an affected version, including org.opennms:opennms-webapp. It affects 2 products.

PackageAffectedFixed in
org.opennms:opennms-webapp MavenAll versions31.0.6
org.opennms:opennms-webapp MavenAll versions31.0.6

Products include Opennms Horizon, Opennms Meridian.

How do I fix CVE-2023-0870?

Upgrade org.opennms:opennms-webapp to 31.0.6 or later.

Is CVE-2023-0870 being exploited?

There is no known exploitation of CVE-2023-0870 in the wild and no public exploit code.

Sources

Also known as GHSA-jxr6-7qg5-8wv6.

Is CVE-2023-0870 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free