{"answers":{"affected":"2 open source packages ship an affected version, including org.opennms:opennms-webapp. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-0870 in the wild and no public exploit code.","fix":"Upgrade org.opennms:opennms-webapp to 31.0.6 or later.","what":"CVE-2023-0870 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-0870 and fix it if it is affected.\n\nWhat it is: CVE-2023-0870 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-0870 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 31.0.6\n- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 31.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-0870/ (Markdown: https://insights.sbomify.com/CVE-2023-0870/index.md)","id":"CVE-2023-0870","markdown":"https://insights.sbomify.com/CVE-2023-0870/index.md","name":"CVE-2023-0870","record":{"aliases":["GHSA-jxr6-7qg5-8wv6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Network monitoring software","requires_auth":"low_privilege","summary":"Attackers can manipulate forms via CSRF to access confidential information and compromise integrity in OpenNMS Meridian and Horizon.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenNMS","cpe":[{"product":"horizon","vendor":"opennms"},{"product":"meridian","vendor":"opennms"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)","id":"CVE-2023-0870","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"An XML External Entity injection vulnerability","id":"CVE-2023-0871"},"packages":[{"ecosystem":"Maven","fixed":["31.0.6"],"introduced":["0"],"last_affected":[],"package":"org.opennms:opennms-webapp","purl":null,"source":"GHSA-jxr6-7qg5-8wv6"},{"ecosystem":"Maven","fixed":["31.0.6"],"introduced":["0"],"last_affected":[],"package":"org.opennms:opennms-webapp","purl":"pkg:maven/org.opennms/opennms-webapp","source":"GHSA-jxr6-7qg5-8wv6"}],"prev":{"headline":"Cross-site scripting in outage/list.htm","id":"CVE-2023-0869"},"products":["Horizon","Meridian"],"published":"2023-03-22","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25931","kev_date_added":null,"published":"2021-05-20"},{"cvss_score":8.8,"headline":"OpenNMS Horizon RCE via JEXL2 expression","id":"CVE-2021-3396","kev_date_added":null,"published":"2021-02-17"},{"cvss_score":8.2,"headline":"ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users","id":"CVE-2023-0872","kev_date_added":null,"published":"2023-08-14"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2020-11886","kev_date_added":null,"published":"2020-04-17"},{"cvss_score":7.1,"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313","kev_date_added":null,"published":"2023-08-17"},{"cvss_score":6.8,"headline":"Plaintext Password Present in the Web logs","id":"CVE-2023-0815","kev_date_added":null,"published":"2023-02-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["The OpenNMS Group","The OpenNMS Group "]},"summary":"Attackers can manipulate forms via CSRF to access confidential information and compromise integrity in OpenNMS Meridian and Horizon.","url":"https://insights.sbomify.com/CVE-2023-0870/"}