# CVE-2023-0870: Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)

> Attackers can manipulate forms via CSRF to access confidential information and compromise integrity in OpenNMS Meridian and Horizon.

- **Severity:** High 8.1 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-jxr6-7qg5-8wv6

## What is CVE-2023-0870?

CVE-2023-0870 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-0870?

2 open source packages ship an affected version, including org.opennms:opennms-webapp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms-webapp` | Maven | All versions | 31.0.6 |
| `org.opennms:opennms-webapp` | Maven | All versions | 31.0.6 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2023-0870?

Upgrade org.opennms:opennms-webapp to 31.0.6 or later.

## Is CVE-2023-0870 being exploited?

There is no known exploitation of CVE-2023-0870 in the wild and no public exploit code.

## Other vulnerabilities in The OpenNMS Group Horizon

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)
- [CVE-2023-40313](https://insights.sbomify.com/CVE-2023-40313/): Disable BeanShell Interpreter Remote Server Mode (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0870 and fix it if it is affected.

What it is: CVE-2023-0870 is a high-severity vulnerability in The OpenNMS Group Horizon, published on 22 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0870 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 31.0.6
- org.opennms:opennms-webapp (Maven): affected all versions; fixed in 31.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0870/ (Markdown: https://insights.sbomify.com/CVE-2023-0870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0870
- OSV: https://osv.dev/vulnerability/CVE-2023-0870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0870/
Summaries are generated and may contain mistakes; the official description above is the record.
